Node Sass version is incompatible with ^4.0.0

邱秋 • 2024年05月11日 • 阅读:19 • nodejs npm

错误很明确, node-sass 和你本地的node 版本不兼容. 实际上这不是兼容不兼容的问题.

原话是node-sass 太拉胯已经被弃用了 ,请使用sass 来代替 node-sass , 像这样

npm uninstall node-sass
npm i sass

如果你一定要 使用 node-sass , 要和node 的版本 相对应, 这是官方给出的解决方案

1 . 先干掉已经安装的node-sass

npm uninstall node-sass

2.看下本地的node 版本

node -v

3.安装对应的版本即可

npm i node-sass@8.x

node-sass 对应的版本如下

NodeJS Supported node-sass version Node Module
Node 20 9.0+ 115
Node 19 8.0+ 111
Node 18 8.0+ 108
Node 17 7.0+, <8.0 102
Node 16 6.0+ 93
Node 15 5.0+, <7.0 88
Node 14 4.14+, <9.0 83
Node 13 4.13+, <5.0 79
Node 12 4.12+, <8.0 72
Node 11 4.10+, <5.0 67
Node 10 4.9+, <6.0 64
Node 8 4.5.3+, <5.0 57
Node <8 <5.0 <57

但是感觉没什么卵用, 还是一堆错误. 正确的姿势是 降级,使用相对较低的版本.

npm uninstall node-sass
npm install --save-dev  --unsafe-perm node-sass@4.14.1

我,秦始皇,打钱!