Node Sass version is incompatible with ^4.0.0

错误很明确, node-sass 和你本地的node 版本不兼容. 实际上这不是兼容不兼容的问题. 原话是node-sass 太拉胯已经被弃用了 ,请使用sass 来代替 node-sass , 像这样npm uninstall node-sassnpm i sass如果你一定要 使用 node-sass , 要和node 的版本 相对应, 这是官方给出的解决方案 1 . 先干掉已经安装的node...阅读全文
67次浏览 0 条评论 0次感谢

npm 发包和管理包及镜像源管理

将撸好的轮子发到NPM(node package manager)上很简单,只需要几个步骤 ,登录账号如果连账号都没有的话,点此创建。使用 npm login 登录根据命令行提示,输入用户名、密码、邮件地址:$ npm loginUsername: chuchurPassword: Email: (this IS public) chuchur@qq.comLogged in as chuchur...阅读全文
245次浏览 0 条评论 2次感谢

node 版本管理(nvm)

简介我们在运行项目时,总是会遇到各种各样的问题,比如node.js版本过高或过低,导致项目无法正常运行,需要去降级或升级, 不同项目必须依赖不同版的 NodeJS 运行环境nvm 应运而生,nvm 是 Mac 下的 node 管理工具,有点类似管理 Ruby 的 rvm ,安装如果需要管理 Windows 下的 node,官方推荐使用 nvmw 或 nvm-windows。不过,nvm-windo...阅读全文
152次浏览 0 条评论 0次感谢