Mysql ER_TRUNCATED_WRONG_VALUE_FOR_FIELD: Incorrect string value
mysql 错误ER_TRUNCATED_WRONG_VALUE_FOR_FIELD: Incorrect string value经过查证,这个原因是MySql编码的问题。UTF-8编码有可能是两个、三个、四个字节。Emoji表情或者某些特殊字符是4个字节,而Mysql的utf8编码最多3个字节,所以数据插不进去。1:找到my.cnfsudo find / -name my.cnf2:修改编码方